Không Chọn được hình khi thêm sản phẩm mới.

Thảo luận trong 'Sử dụng magento - Dành cho người mua' bắt đầu bởi ngu_mali, 4 Tháng tám 2009.

  1. ngu_mali

    ngu_mali New Member

    Chào cả nhà Magentovietnam.Mình có vấn đề này cần mọi người giùp cho.Mình thêm 1 sản phẩm mới nhưng đến tap images thì mình ko thấy mục nào đề chọn hình cả,mà nó cứ hiện ko có hình.(mình dùng ver 1.3.2.1)
    Còn dzụ này nữa ạ(post ở đay chắc lộn chủ đề rồi).Mình có 2 store ngôn ngữ vietnam và english nhưng khi mình đang chọn xem ở ngôn ngữ việtnam khi link bất cứ đâu là nó link về ngôn ngữ english.
    Mong các Bác giúp 2 vấn đề đó nó hành mình cả đêm rồi hic!
    cản ơn mọi người
  2. admin

    admin Mai Văn Hải Staff Member

    Bạn đang xài locahost hay trên 01 Hosting?

    1.Vụ hình ko có phần để upload là do chạy chậm, chưa load xong hoặc do lỗi Script.
    2. Chọn ngôn ngữ này mà hiển thị ngôn ngữ kia là do: bạn chưa cấu hình đúng cách hiển thị ngôn ngữ cho từng store.
    Bạn kiểm tra lại
  3. ngu_mali

    ngu_mali New Member

    Cảm ơn Anh Hải.
    1.Mình đã giải quyết dc vấn đề ngôn ngữ rồi.
    2.Còn vấn đế hình thì chưa ạ.Anh HẢi có thề giúp em về vấn đề này ko ạ(em cài trên local).Anh nói rỏ hơn lỗi do script và cách giải quyết đi ạ.Em đã kiểm tra kỉ lắm rồi ko phài lost chậm đâu a ơi.Thank a ạ
  4. Lee_Min_Han

    Lee_Min_Han New Member

    Đúng như bác Hải nói, đây là lỗi do script. Trong pần upload images của sản pẩm này, nếu mình nhớ ko nhầm thì Magento ứng dụng công nghệ Flex (mình chưa biết nhiều về nó, nên đoán vậy).

    Mình đã từng rewrite block (viết lại, chứ ko pải là chỉnh sửa trực tiếp lên file nguồn như nhiều bạn làm) của thằng này nên cũng tìm hiểu qua về nó. Một số lỗi mà mình đã từng gặp khi modife nó là:
    + Không hiện lên nút....upload
    + Có nút upload, nhưng không thể nào upload được (thông báo lỗi)

    Vậy ko biết là bạn rơi vào tình huống nào. Thường các lỗi này xảy ra khi mà mình modife nó.

    Để có thể biết được lỗi rõ hơn, thì bạn dùng Add-ons Firebug của FF (nhớ enable console lên), và chụp lại hình màn ảnh, kèm lỗi, để mọi người có thể chuẩn đoán được tốt hơn

    Chúc vui
  5. ngu_mali

    ngu_mali New Member

    cảm ơn bác Lee.mình làm dc rồii :lol:
  6. Lee_Min_Han

    Lee_Min_Han New Member

    OK Men, thấy diễn đàn ta, tay nghề ngày càng nâng cao roài đó. Chúc mừng cả nhà.

    Nhưng mình nghĩ để diễn đàn được phát triển hơn nữa, thì các member cần phải post lại hồi âm, phản hồi. Ví dụ: Mình đã mắc lỗi cụ thể ra sao, vì lý do gì, và mình đã giải quyết bằng cách nào...

    Như vậy mới mang đúng tích chất của việc trao đổi kiến thức, người tới sau sẽ ko đi vào vết xe cũ của người đi trước. Đừng như các diễn đàn khác, làm xong việc thì "phủi tay" chẳng để lại lời nhắn :cry:

    Chúc cả nhà vui

    bạn nói đúng ý tui rùi đó.
    Đa số các bạn vô đây là tìm coi có bài viết hướng dẫn vụ mình đang gặp hay không. Có thì tốt, không thì thôi.
    Khi giải quyết được rồi thì chẳng ai chia sẽ kiến thức cả.

    nhưng ko sao pác ah, mình cứ bình tĩnh và hoạt động trong khả năng của chính mình, anh em cũng còn nhiều việc phải lo và phải kiếm thu nhập để sống nữa.

    magento là một hệ thống đáng để học hỏi, nhưng chỉ tiếc là chưa đủ cơ hội để có bản madein Việt Nam
  7. ngu_mali

    ngu_mali New Member

    Hi Cả nhà.Ngu_mali tôi thấy bác Lee có ý hay nên cũng ủng hộ.Các thành viên post các lỗi khi gặp và cách giải quyết cho bà con nghiên cứu.
    Riêng lỗi của tui đơn giản thôi chứ ko phải tui cao xiu gì đâu :lol: .bác nào khi thêm sản phẩm mới khi tab images ko hiện buton browse hay upload file mà ko thông báo lỗi(Ngu toi quên ghi lai rồi,tại dc rồi mừng quá) đại khái có liên quan đến flash hiện thị ở ngay nút upload file thì cài flash player vào là dc(tui nghĩ mãi ko biết nó có pà con gì ko.).restart lại là dc.
  8. Mình cũng bị 1 lỗi tương tự như bạn ngu_mali là có nút upload nhưng khi nhấn upload xong vẫn không thấy images.Mình đã làm theo cách của bạn ngu_mali là cài flash player nhưng vẫn không được.Mình dùng Firebug của firefox thì phát hiện lỗi ở file http://localhost/magento/js/prototype/prototype.js và firebug báo như thế này
    Untitled8.png


    Mong mọi người giúp đỡ mình cách khắc phục!
  9. admin

    admin Mai Văn Hải Staff Member

    Lỗi này xảy ra ở 2 trường hợp:
    1. Magento bản cũ, từ bản 1.7.x trở lên thì không còn lỗi này.
    2. Máy của bạn install flash player quá cũ, hãy download bản mới nhất về, install lại.
    bạn kiểm tra và làm lại thử xem nhé.
  10. Tran Cong Son

    Tran Cong Son New Member

    mình cũng bị lỗi không upload hình được cho sản phẩm, mọi người ai biết về vấn đề này giúp đỡ mình với.Thank!

Chia sẻ trang này