Giúp em lỗi URL Controller action 404 not found

Thảo luận trong 'Các lỗi thường gặp' bắt đầu bởi le van nhien, 5 Tháng ba 2016.

  1. le van nhien

    le van nhien New Member

    Em đang tìm hiểu về magento, bị lỗi khi gõ url: http://127.0.0.1/magento/magento/index.php/index/sayHello hoặc http://127.0.0.1/magento/magento/index.php/index, mà không tìm thấy đường dẫn báo 404 not found , em đang học qua video trên youtube tự viết 1 module riêng . . .




    ---------- Đây là phần TutsPlus_Demo.xml ---- app/etc/modules.xml -------------

    <config>
    <modules>
    <TutsPlus_Demo>
    <active>true</active>
    <codePool>local</codePool>
    </TutsPlus_Demo>
    </modules>
    </config>





    ---------- Đây là phần config.xml ---- TutsPlus/Demo/etc/config.xml -------------

    <?xml version="1.0"?>

    <config>
    <modules>
    <TutsPlus_Demo>
    <version>1.6.1.2</version>
    </TutsPlus_Demo>
    </modules>
    <global>
    <models>
    <demo>
    <class>TutsPlus_Demo_Model</class>
    <!-- <resourceModel>admin_resource</resourceModel> -->
    </demo>
    </models>
    <blocks>
    <demo>
    <class>TutsPlus_Demo_Block</class>
    <!-- <resourceModel>admin_resource</resourceModel> -->
    </demo>
    </blocks>
    <helpers>
    <demo>
    <class>TutsPlus_Demo_Helper</class>
    <!-- <resourceModel>admin_resource</resourceModel> -->
    </demo>
    </helpers>
    <!-- appear info events customer login -->
    <events>
    <customer_login>
    <observers>
    <demo>
    <type>model</type>
    <class>demo/observer</class>
    <method>logCustomer</method>
    </demo>
    </observers>
    </customer_login>
    </events>
    <frontend>
    <routers>
    <tutsplus_demo>
    <use>standard</use>
    <args>
    <module>TutsPlus_Demo</module>
    <frontName>demo</frontName>
    </args>
    </tutsplus_demo>
    </routers>
    </frontend>
    </global>
    </config>




    ---------- Đây là phần IndexController.php ---- TutsPlus/Demo/etc/config.xml -------------

    class TutsPlus_Demo_IndexController extends Mage_Core_Controller_Front_Action
    {
    public function sayHelloAction() {
    echo 'Hello Hello!';
    }


    public function indexAction() {
    echo 'Hello Index!';
    }
    }



    Trong phần admin em đã cấu hính lại

    - system -> Index Management -> Em đã bật tất cả Reindex Data
    - system -> Cache Management -> Disabled tất cả


    Các anh xem giúp em với, hôm qua giờ em sửa ko dc . . .

    Bài viết khác cùng chuyên mục:

  2. le van nhien

    le van nhien New Member

    Em làm trên soucre magento 1.8 thì ok, còn làm trên soucre 1.9 thì nó bị lỗi khi khai báo

Chia sẻ trang này